1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

3.7.8 100% CPU Load

Discussion in 'Bug Reports & Installation Support' started by timjthomas, May 30, 2019.

  1. timjthomas

    timjthomas New Member

    Joined:
    Oct 2, 2010
    Messages:
    21
    Likes Received:
    0
    2018 Macbook Pro 13” with 8gb ram.
     
  2. Krilion_GD

    Krilion_GD Community Manager
    Staff Member

    Joined:
    Aug 1, 2011
    Messages:
    2,180
    Likes Received:
    136
    please post your d20pro.log file.

    upload_2019-5-30_13-28-21.png
     
  3. timjthomas

    timjthomas New Member

    Joined:
    Oct 2, 2010
    Messages:
    21
    Likes Received:
    0
    Attached is the log file. I am doing absolutely nothing -- just loaded the campaign. I also tried creating a new pathfinder campaign and the same result. Once d20Pro opens as a GM, I just let it sit.

    macOS Mojave 10.14.5
    3.7.8 of d20Pro - recently downloaded
     

    Attached Files:

  4. Krilion_GD

    Krilion_GD Community Manager
    Staff Member

    Joined:
    Aug 1, 2011
    Messages:
    2,180
    Likes Received:
    136
    There is nothing in the log that would explain what you are seeing. I'll mention it to @owlbear and see if he has any suggestions
     
  5. Krilion_GD

    Krilion_GD Community Manager
    Staff Member

    Joined:
    Aug 1, 2011
    Messages:
    2,180
    Likes Received:
    136
    @owlbear says, we are working at a solution for this. It is a Java 8 issue, not really a D20PRO thing.
     
  6. timjthomas

    timjthomas New Member

    Joined:
    Oct 2, 2010
    Messages:
    21
    Likes Received:
    0
    Thanks -- wish I could do something. Fan runs 100% of the time with it now.
     
  7. timjthomas

    timjthomas New Member

    Joined:
    Oct 2, 2010
    Messages:
    21
    Likes Received:
    0
    FYI - our session last night had to take a 30 minute break to download 3.7.5. 3.7.8 CPU went up to 300% on two different MacBooks, then went to a spinning ball, and had to be "force quit."

    I'll stick with 3.7.5 until the end of the campaign -- it appeared to work.
     
  8. owlbear

    owlbear Administrator
    Staff Member

    Joined:
    Sep 5, 2011
    Messages:
    608
    Likes Received:
    158
    So I've been talking to our chromium partner about this issue and they claim that the new 7.x version of their library should resolve this issue. I'm working on integrating it now and hope to have something to test by end of day today or tomorrow at the latest.

    The downside to the update is that it puts a hard lower cap on version support for OSX at version 10.9. So the updated builds will require 10.9 or higher to function.
     
  9. mrwinfree

    mrwinfree Member

    Joined:
    May 1, 2016
    Messages:
    76
    Likes Received:
    2
    Well, that stinks. but it's not functional as is in any event. So hurrah for progress!
     
  10. owlbear

    owlbear Administrator
    Staff Member

    Joined:
    Sep 5, 2011
    Messages:
    608
    Likes Received:
    158
    New beta is available for testing with an OSX package here:

    http://pubs.d20pro.com/Public_Beta/3.7.8.4/

    @Krilion_GD will make the full, official announcement in the AM -- I've posted some details to discord as well.

    This build doesn't fully fix the problem, but I'm no longer seeing the spikes over 115... more importantly, the actual performance is really clean and smooth on OSX under the new build -- at least on my aged mac book pro.

    I'm doing more investigation to see what other libraries might be causing the spike and determine if we can trim some of the fat on the builds. She's getting a bit hefty. Fortunately a lot of that is the campaign templates so we can move those out of the installer at a near-future point.
     
  11. owlbear

    owlbear Administrator
    Staff Member

    Joined:
    Sep 5, 2011
    Messages:
    608
    Likes Received:
    158
    well, I went back down to find my test had frozen. I'm going to take the mac with me on my vacation this week and see if I cannot figure out what might be going awry. Since, you know, I won't have the same distractions since it's vacation :p

    Still worth pulling the build and testing on your end. It'd be good to see/hear what the experience is like from someone other then myself!
     

Share This Page