1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Bugs found during my session zero

Discussion in 'Bug Reports & Installation Support' started by Nezzeraj, Jan 10, 2018.

  1. Nezzeraj

    Nezzeraj Member

    Joined:
    Jan 31, 2014
    Messages:
    56
    Likes Received:
    2
    Had my session zero last night and came away with some bugs. Including screenshots for the larger bugs, along with gamelog. Windows 10, 3.7.2.1, 5e Rules, all reproducible.

    1. Using the Pickup Item action makes the characters' entire inventory disappear. It's still shown in the mini window however.

    2. In the roster, passive tokens are being generated randomly and constantly (putting down 1 token generated 3 random passive tokens, for example).

    3. In the Game Log, healing numbers are shown as yellow instead of green.

    4. Healing with spells plays the damage sound effect instead of the healing sound effect.
     

    Attached Files:

  2. Krilion_GD

    Krilion_GD Community Manager
    Staff Member

    Joined:
    Aug 1, 2011
    Messages:
    1,824
    Likes Received:
    132
    for spells and such you need to check the toggle for 'positive' so that the thing using the FLOW that it is does healing rather than damage.

    entries in Passive, just means that token is present on some open map, not necessarily on the map you currently have in focus.

    'Passive' list is a really nice way to drag a token from one map to another if you suddenly find yourself in need of npc x, from an earlier scene.
     
  3. Nezzeraj

    Nezzeraj Member

    Joined:
    Jan 31, 2014
    Messages:
    56
    Likes Received:
    2
    So I figured out the passive bug. It's generating a passive character any time a character is edited from Creature Library and then place a token on the map. I tested this by clearing the map of all tokens and clearing the roster so starting with a clean slate. I edited the Barbarian in the Creature Library only (never placed a token). Then I placed a goblin token on the map. This generated the goblin token as active and the Barbarian as passive, even though I didn't do anything with the Barbarian other than edit it in the library. I repeated this by editing the Barbarian again and the wizard, and placing a boar token. This generated an active boar token, plus ANOTHER Barbarian and the wizard as passives. So it seems to be generating a UID after every change to something in the library whether its on the map or not, and not overwriting if you edit the same token multiple times (i.e. hitting "apply" 3 times after 3 separate edits generates 3 passive roster tokens). I'll attach a screengrab of my test to show this.

    Yes the healing effect works as intended, and the numbers show green in the confirmation window, but it plays the takeDamage.wav file instead of the healDamage.wav file and the number shows white in the game log rather than green. (my guess is that the program can't differentiate the "positive" toggle in spell flow to tell if it's a positive effect except for the numerical value going up for heal rather than down for damage.) I'll include a screengrab of this as well and game log.
     

    Attached Files:

  4. Krilion_GD

    Krilion_GD Community Manager
    Staff Member

    Joined:
    Aug 1, 2011
    Messages:
    1,824
    Likes Received:
    132
    ahhh gotcha, I'll pass along both. thank you for the find..
     
  5. Nezzeraj

    Nezzeraj Member

    Joined:
    Jan 31, 2014
    Messages:
    56
    Likes Received:
    2
    Glad to help! Also don't forget about the disappearing inventory bug! That's a major one lol. Also found one more bug. When a player drops an item, they can't move their token. I have to move them, and then they get control back of it.
     

Share This Page