1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

3.7.8 Win10 High CPU usage

Discussion in 'Bug Reports & Installation Support' started by DM Swan, Aug 7, 2019.

  1. DM Swan

    DM Swan Member

    Joined:
    Jul 26, 2018
    Messages:
    51
    Likes Received:
    0
    We also have this issue and have not found a way to resolve it. Often, it takes our clients multiple times to connect. This even occurs when everyone is on the local network. I've also noticed (using Task Manager) that the Java SE binary application is using 30% of the CPU (all by itself) when D20Pro is running (even when it is just sitting there). And then the total CPU usage can easily jump over 100% if other applications are started when D20Pro is running.
     
    #1 DM Swan, Aug 7, 2019
    Last edited: Aug 7, 2019
  2. Krilion_GD

    Krilion_GD Community Manager
    Staff Member

    Joined:
    Aug 1, 2011
    Messages:
    2,225
    Likes Received:
    138
    This is being worked on to improve it, but if I recall correctly, it's not totally in our hands to resolve. This is an issue on/for Mac.
     
  3. DM Swan

    DM Swan Member

    Joined:
    Jul 26, 2018
    Messages:
    51
    Likes Received:
    0
    I believe both the GM hosting computers in this thread are PCs running Windows 10.
     
  4. Krilion_GD

    Krilion_GD Community Manager
    Staff Member

    Joined:
    Aug 1, 2011
    Messages:
    2,225
    Likes Received:
    138
    If you are seeing unordinary high CPU usage on Win10, there is something other going on. Could you send in your logs (d20pro.log) please?
     
  5. Krilion_GD

    Krilion_GD Community Manager
    Staff Member

    Joined:
    Aug 1, 2011
    Messages:
    2,225
    Likes Received:
    138
    Split those/this threads as they are different in scope.
     
  6. DM Swan

    DM Swan Member

    Joined:
    Jul 26, 2018
    Messages:
    51
    Likes Received:
    0
    The log file is empty. The high CPU usage is with D20Pro running with nobody connected. This is with a AMD A10-7700K Radeon R7 processor, 3.40 GHz, and 32 GM RAM.
     
  7. Krilion_GD

    Krilion_GD Community Manager
    Staff Member

    Joined:
    Aug 1, 2011
    Messages:
    2,225
    Likes Received:
    138
    This is being addressed in the RC2 and will be in the full release. It will auto-retry connection if a collision occurs.
     
  8. Krilion_GD

    Krilion_GD Community Manager
    Staff Member

    Joined:
    Aug 1, 2011
    Messages:
    2,225
    Likes Received:
    138
    It should not be, at the very least it should contain the headers from starting up D20PRO.

    It can be empty if you hit the 'Clear log' from within D20PRO.

    If this is the case, just restart D20PRO and when you see the CPU usage issue, post the log here, please.
     
  9. DM Swan

    DM Swan Member

    Joined:
    Jul 26, 2018
    Messages:
    51
    Likes Received:
    0
    Just launched D20Pro again with Task Manage running. Before starting D20Pro, total CPU usage is about 4-5% with Chrome at 2-3%. When D20Pro starts, the total CPU will jump to 70-80% with the Java Platform binary at 40-50% and Windows Defender at 20-30%. After a few seconds, things settle down - but the Java Platform binary remains right at 30% with the total CPU running at 36%.
     

    Attached Files:

  10. Krilion_GD

    Krilion_GD Community Manager
    Staff Member

    Joined:
    Aug 1, 2011
    Messages:
    2,225
    Likes Received:
    138
    here is an example of normal operation on Win10

    upload_2019-8-8_11-17-2.png
     
  11. DM Swan

    DM Swan Member

    Joined:
    Jul 26, 2018
    Messages:
    51
    Likes Received:
    0
    Here is what ours looks like:
    upload_2019-8-8_9-18-46.png
     
  12. Krilion_GD

    Krilion_GD Community Manager
    Staff Member

    Joined:
    Aug 1, 2011
    Messages:
    2,225
    Likes Received:
    138
    Normal operation with map operations.

    upload_2019-8-8_11-19-31.png
     
  13. Krilion_GD

    Krilion_GD Community Manager
    Staff Member

    Joined:
    Aug 1, 2011
    Messages:
    2,225
    Likes Received:
    138
    So, 30% seems about right with usage.
    If it is not idling down, I have no idea why that would be on your system.
     
  14. DM Swan

    DM Swan Member

    Joined:
    Jul 26, 2018
    Messages:
    51
    Likes Received:
    0
    So the log file shows the headers - and then a couple errors. But no new errors after that.
     

    Attached Files:

  15. Krilion_GD

    Krilion_GD Community Manager
    Staff Member

    Joined:
    Aug 1, 2011
    Messages:
    2,225
    Likes Received:
    138
    These JxBrowser failed threads could be what is spiking it. I'll ask Owlbear to look at this.

    [08 Aug 2019 09:17:10,584] ERROR JFXThread | Failed to run: com.d20pro.temp_extraction.common.jxbrowser.JxBrowserFactory$$Lambda$78/600656341@58739652
    java.lang.NullPointerException: assignCampaign never called
     
  16. DM Swan

    DM Swan Member

    Joined:
    Jul 26, 2018
    Messages:
    51
    Likes Received:
    0
    Yes - just sits about 30% when idle. I have easy Fog of War set and one map open.
     
  17. Krilion_GD

    Krilion_GD Community Manager
    Staff Member

    Joined:
    Aug 1, 2011
    Messages:
    2,225
    Likes Received:
    138
    I'd not suggest 'Easy FOW', it massively resources intensive for what it does. Simple Masks will work much better for you.
     
  18. DM Swan

    DM Swan Member

    Joined:
    Jul 26, 2018
    Messages:
    51
    Likes Received:
    0
    OK. FYI - I launched a different campaign in D20Pro. It still had a high CPU usage, but no error message in the logs.
    upload_2019-8-8_10-4-17.png
     

    Attached Files:

  19. DM Swan

    DM Swan Member

    Joined:
    Jul 26, 2018
    Messages:
    51
    Likes Received:
    0
    Just to test it - I created a new campaign, created a single map, and did not use Fog of War or anything else. No log file errors. But still, high CPU usage when nothing is happening.

    upload_2019-8-8_10-9-57.png
     

    Attached Files:

  20. Krilion_GD

    Krilion_GD Community Manager
    Staff Member

    Joined:
    Aug 1, 2011
    Messages:
    2,225
    Likes Received:
    138
    I wasn't implying that Simple FOW was your issue, only that Masks perform better in general and are way more useful than SFOW.

    Both of those instances show around 30% CPU load, that seems normal to me.

    Where is it spiking to over 100%?
     

Share This Page