1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. While the majority of active discourse on D20PRO has moved to our Discord Channels, this forum is still active and checked-in on regularly by our staff. However, for the very latest information, conversation and/or immediate support, please join us on Discord here: http://discord.gg/Ph38ckM
    Dismiss Notice

Cannot install 3.8.9.12 under MacOS Mojave 10.14.6

Discussion in 'Bug Reports & Installation Support' started by Gnorr, May 22, 2020.

  1. Gnorr

    Gnorr New Member

    Joined:
    May 1, 2011
    Messages:
    23
    Likes Received:
    0
    Hello,

    after my previous unresolved difficulties of getting d20Pro 3.8.9.1 past the jxBrowser errors back in March, I decided to try again with a more recent version, specifically 3.8.9.12 (3.8.9.13 does not have a Mac installer).

    However, after starting the installation (by an explicit right-click / Open combo, to get past MacOS 10.14.6 security), the installer window just shows ``An error occured during the installation. ... The installer encountered an error that caused the installation to fail ...''. No further codes or similar are displayed.

    This occurs regardless whether I try to install to the System /Applications, or below my home directory.

    Any recommendations?
     
  2. Krilion_GD

    Krilion_GD Production/Community Manager
    Staff Member

    Joined:
    Aug 1, 2011
    Messages:
    2,374
    Likes Received:
    140
    .13 should be up shortly for the other builds.
    However, I'll ask Owlbear to take a look at the .12 installer for Mac.
     
  3. Krilion_GD

    Krilion_GD Production/Community Manager
    Staff Member

    Joined:
    Aug 1, 2011
    Messages:
    2,374
    Likes Received:
    140
  4. Gnorr

    Gnorr New Member

    Joined:
    May 1, 2011
    Messages:
    23
    Likes Received:
    0
    OK, the installation worked. And D20Pro starts and allows me to create a new campaign. So progress :) I can open the campaign, and see the default content. But I cannot open a single map (nothing happens after clicking).

    I unfortunately still see the JxBrowser (null) message at the start:

    Code:
    [25 May 2020 15:54:24,417] INFO   D20                       | D20PRO version: 3.8.9.13
    [25 May 2020 15:54:24,418] INFO   D20                       | Java version: 1.8.0_251
    [25 May 2020 15:54:24,418] INFO   D20                       | Operating System: Mac OS X (10.14.6)
    [25 May 2020 15:54:47,575] ERROR  LivePanel_LaunchAbstract  | Failed to init JxBrowser: null
    The complete log file is attached.
     

    Attached Files:

    #4 Gnorr, May 25, 2020 at 7:14 AM
    Last edited: May 25, 2020 at 10:02 AM
  5. Krilion_GD

    Krilion_GD Production/Community Manager
    Staff Member

    Joined:
    Aug 1, 2011
    Messages:
    2,374
    Likes Received:
    140

Share This Page