1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Creature duplication bug

Discussion in 'Bug Reports & Installation Support' started by Tay-Dor, Jan 15, 2017.

  1. Tay-Dor

    Tay-Dor Active Member

    Joined:
    May 15, 2016
    Messages:
    273
    Likes Received:
    42
    Something I've been seeing lately where I duplicate a creature I have on a map and the duplicate looks fine until I open the edit sheet and see the sheet of a completely different creature.

    Here's an example. Today I am populating a map I made this week with the current build of d20Pro (its not a legacy map). I placed one umber hulk and made three duplicates.
    umber1.png

    That top one was the last duplicate. While the others are normal, when I open the edit sheet of the last duplicate, I see the following.
    umber2.png

    I don't have a Wyvern anywhere on this map. On a hunch, I checked my ready room map (where I store some pre-generated random encounters) and found one of the Wyvern's there appeared to be selected.
    umber 3.png

    When I deleted the duplicate Umber Hulk from the first map, it also deleted the Wyvern from my ready room. I made a new duplicate Umber Hulk and it seems to be working fine.
     
  2. Tay-Dor

    Tay-Dor Active Member

    Joined:
    May 15, 2016
    Messages:
    273
    Likes Received:
    42
    Here's today's log file.
     

    Attached Files:

  3. edwardcd

    edwardcd Administrator
    Staff Member

    Joined:
    Oct 13, 2010
    Messages:
    1,374
    Likes Received:
    9
  4. Tay-Dor

    Tay-Dor Active Member

    Joined:
    May 15, 2016
    Messages:
    273
    Likes Received:
    42
    the duplication I was doing was on a completely new (one week old) map, but I'll check the creatures in my ready room.

    All creatures on the other map that was open had 3 digit UIDs.
     
    #4 Tay-Dor, Jan 17, 2017
    Last edited: Jan 17, 2017
  5. cranerat

    cranerat Member

    Joined:
    May 1, 2011
    Messages:
    37
    Likes Received:
    3
    I am also having many problems with duplicating and "Entering/Removing from Initiative". I am constantly trying to regenerate the UID's of creatures to fix this bug but most of the time it isn't working to enable control of the creatures. I have tried numerous times with a creature and usually need to delete the creature and then re-add. This has just started happening in the last couple of months so I have no idea when the patch or code change was, but it is causing me to loose much game play time resetting creatures when I cannot remove them from initiative. A am also having the problem when duplicating creatures two things are happening; 1. Not all the creatures (if any) get duplicated when duplicating groups. 2. Cannot remove creatures from initiative. Usually have to delete and re-add the creature which then will display the same inability to remove from initiative later.
     
  6. owlbear

    owlbear Administrator
    Staff Member

    Joined:
    Sep 5, 2011
    Messages:
    416
    Likes Received:
    131
    noted and added to the internal, pre beta release bucket. Will report in what we find!
     
    Tay-Dor likes this.
  7. cranerat

    cranerat Member

    Joined:
    May 1, 2011
    Messages:
    37
    Likes Received:
    3
    Thanks Owlbear. That's what I like about anyone who has run D20 Pro. You listen and respond. Thanks!
     
    Tay-Dor likes this.

Share This Page