1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. While the majority of active discourse on D20PRO has moved to our Discord Channels, this forum is still active and checked-in on regularly by our staff. However, for the very latest information, conversation and/or immediate support, please join us on Discord here: http://discord.gg/Ph38ckM
    Dismiss Notice

Mac: Cannot open 3.5.7-generated campaigns with 3.8.9.1

Discussion in 'Bug Reports & Installation Support' started by Gnorr, Mar 10, 2020.

  1. Gnorr

    Gnorr New Member

    Joined:
    May 1, 2011
    Messages:
    21
    Likes Received:
    0
    After having set a symlink to point to my old campaign directory (mainly Pathfinder1, created with d20Pro 3.5.7), I can see them in d20pro 3.8.9.1. But when I try to actually open them, nothing happens ( `Initializing' is shown briefly). I have added the log file below.

    I would be grateful for any suggestions how to proceed. E.g., do I have to go through multiple intermediate versions to finally catch up?

    Many thanks!

    [10 Mar 2020 17:42:56,380] INFO D20 | D20PRO version: 3.8.9.1
    [10 Mar 2020 17:42:56,380] INFO D20 | Java version: 1.8.0_221
    [10 Mar 2020 17:42:56,381] INFO D20 | Operating System: Mac OS X (10.14.6)
    [10 Mar 2020 17:43:02,739] ERROR LivePanel_LaunchAbstract | Failed to init JxBrowser: null
    [10 Mar 2020 17:43:06,437] WARN AbstractApp | Old game log not compatible. Trying to recover...
    [10 Mar 2020 17:43:06,437] WARN IgnoreSerialObjectInputsStream | Potentially Fatal Deserialization Operation. java.io.InvalidClassException: Overriding serialized class version mismatch: local serialVersionUID = 7052791124934138445 stream serialVersionUID = 2850960147580249045
    [10 Mar 2020 17:43:06,441] WARN IgnoreSerialObjectInputsStream | Potentially Fatal Deserialization Operation. java.io.InvalidClassException: Overriding serialized class version mismatch: local serialVersionUID = -3118454299963827081 stream serialVersionUID = 2311648666337337407
    [10 Mar 2020 17:43:06,445] WARN IgnoreSerialObjectInputsStream | Potentially Fatal Deserialization Operation. java.io.InvalidClassException: Overriding serialized class version mismatch: local serialVersionUID = 6299353564430927712 stream serialVersionUID = -7438398742993821479
    [10 Mar 2020 17:43:06,447] WARN IgnoreSerialObjectInputsStream | Potentially Fatal Deserialization Operation. java.io.InvalidClassException: Overriding serialized class version mismatch: local serialVersionUID = -5782071560206604768 stream serialVersionUID = 3464410681214202711
    [10 Mar 2020 17:43:06,448] WARN IgnoreSerialObjectInputsStream | Potentially Fatal Deserialization Operation. java.io.InvalidClassException: Overriding serialized class version mismatch: local serialVersionUID = -7739951463202479111 stream serialVersionUID = -37582792944379968
    [10 Mar 2020 17:43:06,450] WARN IgnoreSerialObjectInputsStream | Potentially Fatal Deserialization Operation. java.io.InvalidClassException: Overriding serialized class version mismatch: local serialVersionUID = 2238799778977623744 stream serialVersionUID = 9198045817216461913
    [10 Mar 2020 17:43:06,462] WARN IgnoreSerialObjectInputsStream | Potentially Fatal Deserialization Operation. java.io.InvalidClassException: Overriding serialized class version mismatch: local serialVersionUID = 8838903383953098450 stream serialVersionUID = 8238607397463271976
     
  2. Krilion_GD

    Krilion_GD Production/Community Manager
    Staff Member

    Joined:
    Aug 1, 2011
    Messages:
    2,345
    Likes Received:
    140
    Have you tried copying the campaign folder over to the new install? It might be something with the folder override.
     
  3. Krilion_GD

    Krilion_GD Production/Community Manager
    Staff Member

    Joined:
    Aug 1, 2011
    Messages:
    2,345
    Likes Received:
    140
  4. Gnorr

    Gnorr New Member

    Joined:
    May 1, 2011
    Messages:
    21
    Likes Received:
    0
    Nope, that did not help.

    Folder override: I did not use that, just made a symlink (ln -s) to the campaign folder. That seems to have worked, as I can see the old campaigns in d20Pro 3.8.9.1

    Console Output (note that this has a couple more lines than the log!):

    (base) Thorondor:~ ahk$ cd /Applications/D20PRO//data
    (base) Thorondor:data ahk$ chmod +x ./d20Pro.sh
    (base) Thorondor:data ahk$ ./d20
    d20Pro.prp d20Pro.sh d20pro.exe
    (base) Thorondor:data ahk$ ./d20Pro.sh
    ./
    openjdk version "13.0.2" 2020-01-14
    OpenJDK Runtime Environment AdoptOpenJDK (build 13.0.2+8)
    OpenJDK 64-Bit Server VM AdoptOpenJDK (build 13.0.2+8, mixed mode, sharing)
    (base) Thorondor:data ahk$ [S_API FAIL] SteamAPI_Init() failed; ipcserver GetSteamPath failed.
    [S_API FAIL] SteamAPI_Init() failed
    [13 Mar 2020 13:29:57,437] INFO D20 | D20PRO version: 3.8.9.1
    [13 Mar 2020 13:29:57,439] INFO D20 | Java version: 1.8.0_221
    [13 Mar 2020 13:29:57,439] INFO D20 | Operating System: Mac OS X (10.14.6)
    [13 Mar 2020 13:30:05,271] ERROR LivePanel_LaunchAbstract | Failed to init JxBrowser: null
    [13 Mar 2020 13:30:08,840] WARN AbstractApp | Old game log not compatible. Trying to recover...
    [13 Mar 2020 13:30:08,841] WARN IgnoreSerialObjectInputsStream | Potentially Fatal Deserialization Operation. java.io.InvalidClassException: Overriding serialized class version mismatch: local serialVersionUID = 7052791124934138445 stream serialVersionUID = 2850960147580249045
    [13 Mar 2020 13:30:08,845] WARN IgnoreSerialObjectInputsStream | Potentially Fatal Deserialization Operation. java.io.InvalidClassException: Overriding serialized class version mismatch: local serialVersionUID = -3118454299963827081 stream serialVersionUID = 2311648666337337407
    [13 Mar 2020 13:30:08,850] WARN IgnoreSerialObjectInputsStream | Potentially Fatal Deserialization Operation. java.io.InvalidClassException: Overriding serialized class version mismatch: local serialVersionUID = 6299353564430927712 stream serialVersionUID = -7438398742993821479
    [13 Mar 2020 13:30:08,853] WARN IgnoreSerialObjectInputsStream | Potentially Fatal Deserialization Operation. java.io.InvalidClassException: Overriding serialized class version mismatch: local serialVersionUID = -5782071560206604768 stream serialVersionUID = 3464410681214202711
    [13 Mar 2020 13:30:08,853] WARN IgnoreSerialObjectInputsStream | Potentially Fatal Deserialization Operation. java.io.InvalidClassException: Overriding serialized class version mismatch: local serialVersionUID = -7739951463202479111 stream serialVersionUID = -37582792944379968
    [13 Mar 2020 13:30:08,856] WARN IgnoreSerialObjectInputsStream | Potentially Fatal Deserialization Operation. java.io.InvalidClassException: Overriding serialized class version mismatch: local serialVersionUID = 2238799778977623744 stream serialVersionUID = 9198045817216461913
    [13 Mar 2020 13:30:08,866] WARN IgnoreSerialObjectInputsStream | Potentially Fatal Deserialization Operation. java.io.InvalidClassException: Overriding serialized class version mismatch: local serialVersionUID = 8838903383953098450 stream serialVersionUID = 8238607397463271976
    assignCampaign never called -- null pointer exception in AbstractApp.accessCampaign

    Logfile:

    [13 Mar 2020 13:29:57,437] INFO D20 | D20PRO version: 3.8.9.1
    [13 Mar 2020 13:29:57,439] INFO D20 | Java version: 1.8.0_221
    [13 Mar 2020 13:29:57,439] INFO D20 | Operating System: Mac OS X (10.14.6)
    [13 Mar 2020 13:30:05,271] ERROR LivePanel_LaunchAbstract | Failed to init JxBrowser: null
    [13 Mar 2020 13:30:08,840] WARN AbstractApp | Old game log not compatible. Trying to recover...
    [13 Mar 2020 13:30:08,841] WARN IgnoreSerialObjectInputsStream | Potentially Fatal Deserialization Operation. java.io.InvalidClassException: Overriding serialized class version mismatch: local serialVersionUID = 7052791124934138445 stream serialVersionUID = 2850960147580249045
    [13 Mar 2020 13:30:08,845] WARN IgnoreSerialObjectInputsStream | Potentially Fatal Deserialization Operation. java.io.InvalidClassException: Overriding serialized class version mismatch: local serialVersionUID = -3118454299963827081 stream serialVersionUID = 2311648666337337407
    [13 Mar 2020 13:30:08,850] WARN IgnoreSerialObjectInputsStream | Potentially Fatal Deserialization Operation. java.io.InvalidClassException: Overriding serialized class version mismatch: local serialVersionUID = 6299353564430927712 stream serialVersionUID = -7438398742993821479
    [13 Mar 2020 13:30:08,853] WARN IgnoreSerialObjectInputsStream | Potentially Fatal Deserialization Operation. java.io.InvalidClassException: Overriding serialized class version mismatch: local serialVersionUID = -5782071560206604768 stream serialVersionUID = 3464410681214202711
    [13 Mar 2020 13:30:08,853] WARN IgnoreSerialObjectInputsStream | Potentially Fatal Deserialization Operation. java.io.InvalidClassException: Overriding serialized class version mismatch: local serialVersionUID = -7739951463202479111 stream serialVersionUID = -37582792944379968
    [13 Mar 2020 13:30:08,856] WARN IgnoreSerialObjectInputsStream | Potentially Fatal Deserialization Operation. java.io.InvalidClassException: Overriding serialized class version mismatch: local serialVersionUID = 2238799778977623744 stream serialVersionUID = 9198045817216461913
    [13 Mar 2020 13:30:08,866] WARN IgnoreSerialObjectInputsStream | Potentially Fatal Deserialization Operation. java.io.InvalidClassException: Overriding serialized class version mismatch: local serialVersionUID = 8838903383953098450 stream serialVersionUID = 8238607397463271976
     
  5. Krilion_GD

    Krilion_GD Production/Community Manager
    Staff Member

    Joined:
    Aug 1, 2011
    Messages:
    2,345
    Likes Received:
    140
  6. Krilion_GD

    Krilion_GD Production/Community Manager
    Staff Member

    Joined:
    Aug 1, 2011
    Messages:
    2,345
    Likes Received:
    140
    I'd still just copy that folder over to the new install. Once that campaign is opened in the newer version you'll have problems attempting to open it in the old version, so, it's better off to make a copy rather than face the possibility of making that unusable in the version you are copying it from.
     
  7. Gnorr

    Gnorr New Member

    Joined:
    May 1, 2011
    Messages:
    21
    Likes Received:
    0
    Unfortunately, that did not help. Is there any way to determine more accurately what prevents jxbrowser from starting?

    Failed to init JxBrowser: null

    Is not that informative ...
     
  8. Krilion_GD

    Krilion_GD Production/Community Manager
    Staff Member

    Joined:
    Aug 1, 2011
    Messages:
    2,345
    Likes Received:
    140
    I'd try copying the campaign folder to the proper install location folder by version rather than the above, then rerun the jxBrowser fix. See if maybe it isn't working correctly because of the folder redirection (symlink).
     
  9. owlbear

    owlbear Administrator
    Staff Member

    Joined:
    Sep 5, 2011
    Messages:
    634
    Likes Received:
    160
    Hello, sorry for the delay, I've been ill (unrelated to COVID19). Anyway, I noticed that the application is running on OpenJDK on your system. This will not work with the current builds. I have not converted the code to support OpenJDK as the original Mindgene folk had many a library which required Oracle and it will take time to write/find replacements before we make the push away from Oracle's JDK.

    The Mac version of the application ships with the JRE we're using to run the application. If you run D20PRO from the included shell script it will execute from the included JRE (Java 8_211) instead of your system installed JRE (OpenJDK).
     
  10. owlbear

    owlbear Administrator
    Staff Member

    Joined:
    Sep 5, 2011
    Messages:
    634
    Likes Received:
    160
    And apparently updates were slow. you already got that far :p looking at the rest of the thread now (sorry about that)

    Actually I do not think I was crazy. It does look like the logs are showing OpenJDK being called but also Java 8_211? that is very strange.
     
  11. owlbear

    owlbear Administrator
    Staff Member

    Joined:
    Sep 5, 2011
    Messages:
    634
    Likes Received:
    160
    This is the bit that has me thinking there something odd going on with your java set up -- which would definitely cause these issues:

    upload_2020-3-18_11-59-19.png

    If I understand what I'm seeing here. the 1.8.0_221 version is actually being faked by your OpenJDK 13 build -- Java 9 and higher is radically different than Java 8 was. And OpenJDK doesn't support many of the Sun/Oracle native libraries so is not compatible, even in legacy mode.
     

    Attached Files:

Share This Page